summaryrefslogtreecommitdiffstats
path: root/lass/1systems/aergia/source.nix
diff options
context:
space:
mode:
authorlassulus <git@lassul.us>2023-01-26 16:13:42 +0100
committerlassulus <git@lassul.us>2023-01-26 16:13:42 +0100
commit18efc15b2a2694dac07f89d33bb1243492358a88 (patch)
tree049c8953040d0d6463dedbeaebd3067239862e9c /lass/1systems/aergia/source.nix
parentdbfc4044ef79153f2b80b0d6c252ddbf2ab476ab (diff)
l aergia.r: init
Diffstat (limited to 'lass/1systems/aergia/source.nix')
-rw-r--r--lass/1systems/aergia/source.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/lass/1systems/aergia/source.nix b/lass/1systems/aergia/source.nix
new file mode 100644
index 00000000..abbf26c7
--- /dev/null
+++ b/lass/1systems/aergia/source.nix
@@ -0,0 +1,21 @@
+{ lib, pkgs, test, ... }: let
+ npkgs = lib.importJSON ../../../krebs/nixpkgs-unstable.json;
+in {
+ nixpkgs = (if test then lib.mkForce ({ derivation = let
+ rev = npkgs.rev;
+ sha256 = npkgs.sha256;
+ in ''
+ with import (builtins.fetchTarball {
+ url = "https://github.com/nixos/nixpkgs/archive/${rev}.tar.gz";
+ sha256 = "${sha256}";
+ }) {};
+ pkgs.fetchFromGitHub {
+ owner = "nixos";
+ repo = "nixpkgs";
+ rev = "${rev}";
+ sha256 = "${sha256}";
+ }
+ ''; }) else {
+ git.ref = lib.mkForce npkgs.rev;
+ });
+}