summaryrefslogtreecommitdiffstats
path: root/lass/1systems/aergia/disk.nix
diff options
context:
space:
mode:
authorlassulus <git@lassul.us>2023-01-26 16:13:42 +0100
committerlassulus <git@lassul.us>2023-01-26 16:13:42 +0100
commit18efc15b2a2694dac07f89d33bb1243492358a88 (patch)
tree049c8953040d0d6463dedbeaebd3067239862e9c /lass/1systems/aergia/disk.nix
parentdbfc4044ef79153f2b80b0d6c252ddbf2ab476ab (diff)
l aergia.r: init
Diffstat (limited to 'lass/1systems/aergia/disk.nix')
-rw-r--r--lass/1systems/aergia/disk.nix64
1 files changed, 64 insertions, 0 deletions
diff --git a/lass/1systems/aergia/disk.nix b/lass/1systems/aergia/disk.nix
new file mode 100644
index 00000000..0ae0892e
--- /dev/null
+++ b/lass/1systems/aergia/disk.nix
@@ -0,0 +1,64 @@
+{ lib, ... }:
+{
+ disk = {
+ main = {
+ type = "disk";
+ device = "/dev/nvme0n1";
+ content = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ name = "boot";
+ type = "partition";
+ start = "0";
+ end = "1M";
+ part-type = "primary";
+ flags = ["bios_grub"];
+ }
+ {
+ type = "partition";
+ name = "ESP";
+ start = "1MiB";
+ end = "1GiB";
+ fs-type = "fat32";
+ bootable = true;
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ };
+ }
+ {
+ name = "root";
+ type = "partition";
+ start = "1GiB";
+ end = "100%";
+ content = {
+ type = "luks";
+ name = "aergia1";
+ content = {
+ type = "btrfs";
+ extraArgs = "-f"; # Override existing partition
+ subvolumes = {
+ # Subvolume name is different from mountpoint
+ "/rootfs" = {
+ mountpoint = "/";
+ };
+ # Mountpoints inferred from subvolume name
+ "/home" = {
+ mountOptions = [];
+ };
+ "/nix" = {
+ mountOptions = [];
+ };
+ };
+ };
+ };
+ }
+ ];
+ };
+ };
+ };
+}
+