summaryrefslogtreecommitdiffstats
path: root/krebs/krops.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2020-03-17 21:04:36 +0100
committerlassulus <lassulus@lassul.us>2020-03-17 21:04:36 +0100
commitc2685109c0541640333130bc217439fec86bcdb9 (patch)
tree492996164bcd784745dc56bb8c44e0482c7be75d /krebs/krops.nix
parent23cba7672c9ede59102ad439b9a76ee8abdaf006 (diff)
parent3493cd74a1f6942566fbad4b89f4d3c84f964868 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'krebs/krops.nix')
-rw-r--r--krebs/krops.nix25
1 files changed, 13 insertions, 12 deletions
diff --git a/krebs/krops.nix b/krebs/krops.nix
index 1f439f62..608e46df 100644
--- a/krebs/krops.nix
+++ b/krebs/krops.nix
@@ -31,18 +31,19 @@
};
};
stockholm.file = toString ../.;
- stockholm-version.pipe = toString (pkgs.writeDash "${name}-version" ''
- set -efu
- cd ${lib.escapeShellArg stockholm.file}
- V=$(${pkgs.coreutils}/bin/date +%y.%m)
- if test -d .git; then
- V=$V.git.$(${pkgs.git}/bin/git describe --always --dirty)
- case $V in (*-dirty)
- V=$V@''${HOSTNAME-$(${pkgs.nettools}/bin/hostname)}
- esac
- fi
- printf %s "$V"
- '');
+ stockholm-version.pipe =
+ toString (pkgs.writers.writeDash "${name}-version" ''
+ set -efu
+ cd ${lib.escapeShellArg stockholm.file}
+ V=$(${pkgs.coreutils}/bin/date +%y.%m)
+ if test -d .git; then
+ V=$V.git.$(${pkgs.git}/bin/git describe --always --dirty)
+ case $V in (*-dirty)
+ V=$V@''${HOSTNAME-$(${pkgs.nettools}/bin/hostname)}
+ esac
+ fi
+ printf %s "$V"
+ '');
};
source ={ test }: lib.evalSource [