summaryrefslogtreecommitdiffstats
path: root/krebs/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-20 20:24:25 +0200
committertv <tv@shackspace.de>2015-10-20 20:24:25 +0200
commit9cb1fdc946aecc96bd9bbadca77b6d7e3c87abd3 (patch)
tree8fdfaedfe6df6a9af09a19e2cd2a20d91e6be3f2 /krebs/default.nix
parentacb53c23dcb11de02e642e7f99e83401531e48c1 (diff)
populate dir: reduce noise in error message
Diffstat (limited to 'krebs/default.nix')
-rw-r--r--krebs/default.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/krebs/default.nix b/krebs/default.nix
index 40b3550c..3e86c046 100644
--- a/krebs/default.nix
+++ b/krebs/default.nix
@@ -216,16 +216,13 @@ let out = {
--delete-excluded \
-vrLptgoD \
${config.path}/ \
- ${target-url}
+ root@${target}:${config.target-path}
'';
- current-url = "${current-user-name}@${current-host.name}";
- source-url = "file://${config.host.name}${config.path}";
- target-url = "root@${target}:${config.target-path}";
in
if can-push then push-method else
- throw
- # /!\ revise this message when using more than just push-method
- "No way to push ${source-url} from ${current-url} to ${target-url}";
+ let dir = "file://${config.host.name}${config.path}"; in
+ # /!\ revise this message when using more than just push-method
+ throw "No way to push ${dir} from ${current-host.name} to ${target}";
methods.git = config:
rootssh target ''