summaryrefslogtreecommitdiffstats
path: root/krebs/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-02-04 04:44:26 +0100
committertv <tv@krebsco.de>2016-02-04 04:46:36 +0100
commit65977c6108d9517d58a6bd6ce8676c6a7b97615e (patch)
tree7e6c1c1de7572f343b91ca814734a670b29ccf27 /krebs/default.nix
parent8e3d27a9499bb70d5d033e4fd007aa53dea70b18 (diff)
RIP current-date
Diffstat (limited to 'krebs/default.nix')
-rw-r--r--krebs/default.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/krebs/default.nix b/krebs/default.nix
index df2d9548..e9ee71b3 100644
--- a/krebs/default.nix
+++ b/krebs/default.nix
@@ -1,5 +1,4 @@
-{ current-date
-, current-host-name
+{ current-host-name
, current-user-name
, lib
, stockholm
@@ -21,7 +20,6 @@ let out = {
config = get-config system;
in ''
#! /bin/sh
- # ${current-date} ${current-user-name}@${current-host-name}
# krebs.deploy
set -efu
(${populate args})
@@ -39,7 +37,6 @@ let out = {
config = get-config system;
in ''
#! /bin/sh
- # ${current-date} ${current-user-name}@${current-host-name}
# krebs.infest
set -efu
@@ -64,7 +61,6 @@ let out = {
config = get-config system;
in ''
#! /bin/sh
- # ${current-date} ${current-user-name}@${current-host-name}
# krebs.init
set -efu
@@ -100,7 +96,6 @@ let out = {
}@args: let
in ''
#! /bin/sh
- # ${current-date} ${current-user-name}@${current-host-name}
# krebs.nixos-install
(${populate (args // { root = "/mnt"; })})
@@ -196,7 +191,6 @@ let out = {
nix-env \
--show-trace \
-f '<stockholm>' \
- --argstr current-date ${lib.shell.escape current-date} \
--argstr current-host-name ${lib.shell.escape current-host-name} \
--argstr current-user-name ${lib.shell.escape current-user-name} \
--profile ${lib.shell.escape config.krebs.build.profile} \
@@ -216,7 +210,6 @@ let out = {
}@args:
let out = ''
#! /bin/sh
- # ${current-date} ${current-user-name}@${current-host-name}
set -efu
${lib.concatStringsSep "\n"
(lib.concatMap