summaryrefslogtreecommitdiffstats
path: root/krebs/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-20 20:06:17 +0200
committertv <tv@shackspace.de>2015-10-20 20:09:41 +0200
commit2efaf0f219850cd02cc77cb41d6c1c1bdd9de6ba (patch)
tree6c83f08e3583ce49dfca80155e01c403cda599bd /krebs/default.nix
parentb2fd7be3ff755e17e9d303f03b9a2345623fd384 (diff)
populate dir: improve error message
Diffstat (limited to 'krebs/default.nix')
-rw-r--r--krebs/default.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/krebs/default.nix b/krebs/default.nix
index c23cf152..5e6595ce 100644
--- a/krebs/default.nix
+++ b/krebs/default.nix
@@ -221,11 +221,15 @@ let out = {
${config.path}/ \
root@${target}:${config.target-path}
'';
- url = "file://${config.host.name}${config.path}";
+ current-url = "${current-user-name}@${current-host.name}";
+ source-url = "file://${config.host.name}${config.path}";
+ target-url = "root@${target}:${config.target-path}";
in
#if can-link then link-method else
if can-push then push-method else
- throw "cannot source ${url}";
+ throw
+ # /!\ revise this message when using more than just push-method
+ "No way to push ${source-url} from ${current-url} to ${target-url}";
methods.git = config:
rootssh target ''