summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/test
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-03-10 15:23:36 +0100
committermakefu <github@syntax-fehler.de>2016-03-10 15:23:36 +0100
commit8629a9de8bcc98686d10387c02489178183b616d (patch)
treee66c0dee71702648ee4aaf8a625ed80fba23ab77 /krebs/5pkgs/test
parentcf416ecd6848a4f9e96126220fe86c50b2e86ca7 (diff)
infest-cac-centos7: target => system
Diffstat (limited to 'krebs/5pkgs/test')
-rw-r--r--krebs/5pkgs/test/infest-cac-centos7/default.nix2
-rwxr-xr-xkrebs/5pkgs/test/infest-cac-centos7/notes10
2 files changed, 6 insertions, 6 deletions
diff --git a/krebs/5pkgs/test/infest-cac-centos7/default.nix b/krebs/5pkgs/test/infest-cac-centos7/default.nix
index 5dbb4ebd..9b14bf48 100644
--- a/krebs/5pkgs/test/infest-cac-centos7/default.nix
+++ b/krebs/5pkgs/test/infest-cac-centos7/default.nix
@@ -5,7 +5,7 @@
stdenv.mkDerivation rec {
name = "${shortname}-${version}";
shortname = "infest-cac-centos7";
- version = "0.2.6";
+ version = "0.2.7";
src = ./notes;
diff --git a/krebs/5pkgs/test/infest-cac-centos7/notes b/krebs/5pkgs/test/infest-cac-centos7/notes
index fafc1157..ab6bc557 100755
--- a/krebs/5pkgs/test/infest-cac-centos7/notes
+++ b/krebs/5pkgs/test/infest-cac-centos7/notes
@@ -16,7 +16,7 @@ krebs_cred=${krebs_cred-./cac.json}
retiolum_key=${retiolum_key-./retiolum.rsa_key.priv}
# build this host
user=${user:-shared}
-target=${target_system:-test-centos7}
+system=${target_system:-test-centos7}
log(){
echo "[$(date +"%Y-%m-%d %T")] $@" 2>&1
@@ -45,8 +45,8 @@ if test ! -r "$retiolum_key";then
echo "\$retiolum_key=$retiolum_key must be readable"; exit 1
fi
-if test ! -r "${user}/1systems/${target}.nix" ;then
- echo "cannot find ${user}/1systems/${target}.nix , not started in stockholm directory?"
+if test ! -r "${user}/1systems/${system}.nix" ;then
+ echo "cannot find ${user}/1systems/${system}.nix , not started in stockholm directory?"
exit 1
fi
@@ -86,7 +86,7 @@ while true;do
id=servername:$name
log "got a working machine, id=$id"
else
- elog "Unable to build a virtual machine, retrying in 15 seconds"
+ log "Unable to build a virtual machine, retrying in 15 seconds"
log "Output of build program: $out"
sleep 15
continue
@@ -153,7 +153,7 @@ make install \
LOGNAME=${user} \
SSHPASS="$(cac-api getserver $id | jq -r .rootpass)" \
ssh='sshpass -e ssh -S none -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null' \
- system=${target} \
+ system=${system} \
target=$ip
log "finalizing installation"
cac-api ssh $id < krebs/4lib/infest/finalize.sh