summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/test
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-02-19 18:56:01 +0100
committertv <tv@krebsco.de>2016-02-20 02:02:08 +0100
commit2ff36bad032df0900e13a3ec743b09064c3d07c6 (patch)
tree789b4e40846d673d0eabc87d001f0ef01cc48040 /krebs/5pkgs/test
parenta60767166201066eea80b7f53fdcc2e623dc769a (diff)
test infest-cac-centos7: use make install interface
Diffstat (limited to 'krebs/5pkgs/test')
-rwxr-xr-xkrebs/5pkgs/test/infest-cac-centos7/notes16
1 files changed, 8 insertions, 8 deletions
diff --git a/krebs/5pkgs/test/infest-cac-centos7/notes b/krebs/5pkgs/test/infest-cac-centos7/notes
index db80c0c6..6bb0258a 100755
--- a/krebs/5pkgs/test/infest-cac-centos7/notes
+++ b/krebs/5pkgs/test/infest-cac-centos7/notes
@@ -1,4 +1,4 @@
-# nix-shell -p gnumake jq openssh cac-api cac-panel
+# nix-shell -p gnumake jq openssh cac-api cac-panel sshpass
set -eufx
# 2 secrets are required:
@@ -99,7 +99,7 @@ defer "cac-api delete $id;$old_trapstr"
mkdir -p shared/2configs/temp
cac-api generatenetworking $id > \
shared/2configs/temp/networking.nix
-# new temporary ssh key we will use to log in after infest
+# new temporary ssh key we will use to log in after install
ssh-keygen -f $krebs_ssh -N ""
cp $retiolum_key $krebs_secrets/retiolum.rsa_key.priv
# we override the directories for secrets and stockholm
@@ -118,12 +118,12 @@ _: {
}
EOF
-LOGNAME=shared make eval get=krebs.infest \
- target=derp system=test-centos7 filter=json \
- | sed -e "s#^ssh.*<<#cac-api ssh $id<<#" \
- -e "/^rsync/a -e 'cac-api ssh $id' \\\\" \
- -e "s#root.derp:#:#" > $krebs_secrets/infest
-sh -x $krebs_secrets/infest
+make install \
+ LOGNAME=shared \
+ SSHPASS="$(cac-api getserver $id | jq -r .rootpass)" \
+ ssh='sshpass -e ssh -S none -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null' \
+ system=test-centos7 \
+ target=$ip
# TODO: generate secrets directory $krebs_secrets for nix import
cac-api powerop $id reset