summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/prison-break/straight-plugin.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-04-26 20:31:03 +0200
committermakefu <github@syntax-fehler.de>2019-04-26 20:31:21 +0200
commit95f6a06c5acfb6054236ea2f5aee42975dd909ec (patch)
tree93e47d94cd23eb62884d5ccf451209b92f09f9e9 /krebs/5pkgs/simple/prison-break/straight-plugin.nix
parentd19aedb81c0e5aa7a292ff00aaf870ab3c0579ea (diff)
prison-break: move to krebs
Diffstat (limited to 'krebs/5pkgs/simple/prison-break/straight-plugin.nix')
-rw-r--r--krebs/5pkgs/simple/prison-break/straight-plugin.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/prison-break/straight-plugin.nix b/krebs/5pkgs/simple/prison-break/straight-plugin.nix
new file mode 100644
index 00000000..606c60b5
--- /dev/null
+++ b/krebs/5pkgs/simple/prison-break/straight-plugin.nix
@@ -0,0 +1,22 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+}:
+
+buildPythonPackage rec {
+ pname = "straight-plugin";
+ version = "1.5.0";
+
+ src = fetchPypi {
+ pname = "straight.plugin";
+ inherit version;
+ sha256 = "818a7641068932ed6436d0af0a3bb77bbbde29df0a7142c8bd1a249e7c2f0d38";
+ };
+
+ meta = with lib; {
+ description = "A simple namespaced plugin facility";
+ homepage = https://github.com/ironfroggy/straight.plugin;
+ license = licenses.mit;
+ maintainers = [ maintainers.makefu ];
+ };
+}