summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/hashPassword
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-05-24 01:43:50 +0200
committertv <tv@krebsco.de>2017-05-24 01:43:50 +0200
commitf0b98bd0114df1e1ebb82ff300f9532d86b3eb18 (patch)
tree58a39173f7d6d7caa10a7b8fec1b5a1e54f0c08c /krebs/5pkgs/simple/hashPassword
parent46d6506916f699e3b707dc41cd68c92b98e50e5a (diff)
krebs/5pkgs: move simple pkgs to a subdir
Diffstat (limited to 'krebs/5pkgs/simple/hashPassword')
-rw-r--r--krebs/5pkgs/simple/hashPassword/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/hashPassword/default.nix b/krebs/5pkgs/simple/hashPassword/default.nix
new file mode 100644
index 00000000..3da65ad7
--- /dev/null
+++ b/krebs/5pkgs/simple/hashPassword/default.nix
@@ -0,0 +1,15 @@
+{ lib, pkgs, ... }:
+
+pkgs.writeDashBin "hashPassword" ''
+ # usage: hashPassword
+ set -euf
+
+ export PATH=${lib.makeBinPath (with pkgs; [
+ coreutils
+ mkpasswd
+ openssl
+ ])}
+
+ salt=$(openssl rand -base64 16 | tr -d '+=' | head -c 16)
+ exec mkpasswd -m sha-512 -S "$salt"
+''