summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/git-hooks/default.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2021-09-05 22:51:37 +0200
committerlassulus <lassulus@lassul.us>2021-09-05 23:09:21 +0200
commitb471ff4191011b000f60dd2c6dafc6e5ed9458c2 (patch)
treed83a70b841bda26335a2771fcf5470a5afce9222 /krebs/5pkgs/simple/git-hooks/default.nix
parentaaae1b2f5b6532ae6f5def1678957e2a6dc00c28 (diff)
irc-announce: add tls flag
Diffstat (limited to 'krebs/5pkgs/simple/git-hooks/default.nix')
-rw-r--r--krebs/5pkgs/simple/git-hooks/default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/git-hooks/default.nix b/krebs/5pkgs/simple/git-hooks/default.nix
index 0a2c8441..012c4ccf 100644
--- a/krebs/5pkgs/simple/git-hooks/default.nix
+++ b/krebs/5pkgs/simple/git-hooks/default.nix
@@ -12,6 +12,7 @@ with import <stockholm/lib>;
, port ? 6667
, refs ? []
, server
+ , tls ? false
, verbose ? false
}: /* sh */ ''
#! /bin/sh
@@ -39,6 +40,7 @@ with import <stockholm/lib>;
nick=${escapeShellArg nick}
channel=${escapeShellArg channel}
server=${escapeShellArg server}
+ tls=${escapeShellArg tls}
port=${toString port}
host=$nick
@@ -114,6 +116,7 @@ with import <stockholm/lib>;
"$port" \
"$nick" \
"$channel" \
+ "tls" \
"$message"
fi
'';