summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/flameshot-once/config.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2023-02-04 21:52:51 +0100
committertv <tv@krebsco.de>2023-02-05 02:29:31 +0100
commitafe16677affb35291fc64def0ccb0656a5c47647 (patch)
treed2de4f4a50538eedb92d33f4a44c59d3d905f79c /krebs/5pkgs/simple/flameshot-once/config.nix
parent8056151181e6b49ad3c1b80cdfc94a18e49846fc (diff)
flameshot-once: add dev tools
Diffstat (limited to 'krebs/5pkgs/simple/flameshot-once/config.nix')
-rw-r--r--krebs/5pkgs/simple/flameshot-once/config.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/flameshot-once/config.nix b/krebs/5pkgs/simple/flameshot-once/config.nix
index 817c700a..24df403a 100644
--- a/krebs/5pkgs/simple/flameshot-once/config.nix
+++ b/krebs/5pkgs/simple/flameshot-once/config.nix
@@ -79,6 +79,8 @@ in
};
settings = {
# Options without a description are not documented in flameshot's README.
+ # Compare with:
+ # nix-shell -p flameshot-once.dev --run get-recognizedGeneralOptions
General = mapAttrs (_: recursiveUpdate { default = null; }) {
allowMultipleGuiInstances = mkOption {
description = ''
@@ -100,6 +102,8 @@ in
};
buttons = let
buttonTypes = {
+ # Generated with:
+ # nix-shell -p flameshot-once.dev --run get-buttonTypes
TYPE_PENCIL = 0;
TYPE_DRAWER = 1;
TYPE_ARROW = 2;
@@ -126,6 +130,8 @@ in
TYPE_ACCEPT = 23;
};
iterableButtonTypes = [
+ # Generated with:
+ # nix-shell -p flameshot-once.dev --run get-iterableButtonTypes
"TYPE_ACCEPT"
"TYPE_ARROW"
"TYPE_CIRCLE"
@@ -359,6 +365,8 @@ in
};
};
Shortcuts = genAttrs [
+ # Generated with:
+ # nix-shell -p flameshot-once.dev --run get-Shortcuts
"TYPE_ACCEPT"
"TYPE_ARROW"
"TYPE_CIRCLE"