summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/buildbot-classic/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2021-06-10 21:42:06 +0200
committertv <tv@krebsco.de>2021-06-10 21:42:06 +0200
commit0e6e8b7188b4a2aab7ca467cb20514a70ba09011 (patch)
treecfa9ab8a1a83e0dd139255cf7f7b29bf9a37fdf6 /krebs/5pkgs/simple/buildbot-classic/default.nix
parent44c4cb6a453f5bc34c870caa6802548c099e9435 (diff)
parent04a081a3be600cc5e74aadd4f0fee899d6987a85 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'krebs/5pkgs/simple/buildbot-classic/default.nix')
-rw-r--r--krebs/5pkgs/simple/buildbot-classic/default.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/krebs/5pkgs/simple/buildbot-classic/default.nix b/krebs/5pkgs/simple/buildbot-classic/default.nix
index c127d298..5e075f1a 100644
--- a/krebs/5pkgs/simple/buildbot-classic/default.nix
+++ b/krebs/5pkgs/simple/buildbot-classic/default.nix
@@ -1,6 +1,9 @@
-{ pkgs, fetchFromGitHub, python2Packages, git, ... }:
+{ pkgs, fetchFromGitHub, python2Packages, git, ... }: let
-python2Packages.buildPythonApplication rec {
+ # we need the old sqlparse since the new one is python2 incompatible
+ sqlparse = python2Packages.callPackage ./sqlparse.nix {};
+
+in python2Packages.buildPythonApplication rec {
name = "buildbot-classic-${version}";
version = "0.8.18";
namePrefix = "";
@@ -18,7 +21,7 @@ python2Packages.buildPythonApplication rec {
python2Packages.jinja2
python2Packages.twisted
python2Packages.dateutil
- python2Packages.sqlalchemy_migrate
+ (python2Packages.sqlalchemy_migrate.override { sqlparse = sqlparse; })
python2Packages.pysqlite
pkgs.coreutils
];