summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2021-10-12 19:36:09 +0200
committerlassulus <lassulus@lassul.us>2021-10-12 20:53:45 +0200
commit77c3aab5b860a952e9d83db56aefe23ee04ccebc (patch)
treec1c57e5c2485f4613ff5ce3dd7df6c5eb5f23512 /krebs/5pkgs/haskell
parent780a04e991c46a111c38281fced75f9c38e972f8 (diff)
pkgs: use relative stockholm.lib
Diffstat (limited to 'krebs/5pkgs/haskell')
-rw-r--r--krebs/5pkgs/haskell/blessings.nix5
-rw-r--r--krebs/5pkgs/haskell/default.nix5
-rw-r--r--krebs/5pkgs/haskell/email-header.nix8
3 files changed, 11 insertions, 7 deletions
diff --git a/krebs/5pkgs/haskell/blessings.nix b/krebs/5pkgs/haskell/blessings.nix
index b0e81fdc..00299ca6 100644
--- a/krebs/5pkgs/haskell/blessings.nix
+++ b/krebs/5pkgs/haskell/blessings.nix
@@ -1,6 +1,7 @@
-with import <stockholm/lib>;
-{ mkDerivation, base, fetchgit, hspec, QuickCheck, stdenv, text }: let
+{ mkDerivation, base, fetchgit, hspec, QuickCheck, stdenv, stockholm, text }:
+with stockholm.lib;
+let
cfg = {
"18.03" = {
version = "1.1.0";
diff --git a/krebs/5pkgs/haskell/default.nix b/krebs/5pkgs/haskell/default.nix
index e824699f..98cbcb3b 100644
--- a/krebs/5pkgs/haskell/default.nix
+++ b/krebs/5pkgs/haskell/default.nix
@@ -1,8 +1,9 @@
-with import <stockholm/lib>;
+self: super:
+with self.stockholm.lib;
+
let
overrides = self: super: mapNixDir (path: self.callPackage path {}) ./.;
in
-self: super:
{
haskell = super.haskell // {
packages = mapAttrs (name: value:
diff --git a/krebs/5pkgs/haskell/email-header.nix b/krebs/5pkgs/haskell/email-header.nix
index 94b33e28..ccc32c09 100644
--- a/krebs/5pkgs/haskell/email-header.nix
+++ b/krebs/5pkgs/haskell/email-header.nix
@@ -1,8 +1,10 @@
-with import <stockholm/lib>;
{ mkDerivation, attoparsec, base, base64-bytestring, bytestring
, case-insensitive, containers, exceptions, fetchgit, QuickCheck
-, stdenv, tasty, tasty-quickcheck, text, text-icu, time
-}: let
+, stdenv, stockholm, tasty, tasty-quickcheck, text, text-icu, time
+}:
+with stockholm.lib;
+
+let
cfg = {
"18.03" = {