summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2022-04-05 22:16:29 +0200
committertv <tv@krebsco.de>2022-04-05 22:29:55 +0200
commit1407ad3502a7dd46d6e432b7ccc013bc80341bb1 (patch)
tree612042b7178ce8bf16990c375205a627082cfce6 /krebs/5pkgs/haskell
parent8d3688ecfd4a0f1a8908a0cb471e7b7792d9b54b (diff)
pager: init at 1.0.0
Diffstat (limited to 'krebs/5pkgs/haskell')
-rw-r--r--krebs/5pkgs/haskell/pager.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/pager.nix b/krebs/5pkgs/haskell/pager.nix
new file mode 100644
index 00000000..3c9f8046
--- /dev/null
+++ b/krebs/5pkgs/haskell/pager.nix
@@ -0,0 +1,23 @@
+{ mkDerivation, base, blessings, bytestring, containers
+, data-default, hack, lib, optparse-applicative, probability
+, scanner, speculate, split, terminal-size, text, unix, X11
+, fetchgit
+}:
+mkDerivation {
+ pname = "pager";
+ version = "1.0.0";
+ src = fetchgit {
+ url = "https://cgit.krebsco.de/pager";
+ sha256 = "1kqd27faxinkwpxancyk0xl6n7ljlc8iqhnnq85l76bk4qi9b45i";
+ rev = "f4cdf79bd4a75e9eafe68b9a908f4cc68682b7ef";
+ fetchSubmodules = true;
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ base blessings bytestring containers data-default hack
+ optparse-applicative probability scanner speculate split
+ terminal-size text unix X11
+ ];
+ license = lib.licenses.mit;
+}