summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-05-24 02:28:37 +0200
committertv <tv@krebsco.de>2017-05-24 02:28:37 +0200
commite733b7e07d091593ebbe9274be0e71e541db4c06 (patch)
tree8ab0805b64feb01750da68a1f9eaf910f14cc693 /krebs/5pkgs/default.nix
parent00b9970aae4e2cb472c793b9809bfb18fff8a37f (diff)
krebs/5pkgs: reformat
Diffstat (limited to 'krebs/5pkgs/default.nix')
-rw-r--r--krebs/5pkgs/default.nix50
1 files changed, 27 insertions, 23 deletions
diff --git a/krebs/5pkgs/default.nix b/krebs/5pkgs/default.nix
index 820f0cdc..39e89a4b 100644
--- a/krebs/5pkgs/default.nix
+++ b/krebs/5pkgs/default.nix
@@ -1,29 +1,33 @@
-pkgs: oldpkgs:
with import <stockholm/lib>;
- foldl' mergeAttrs {}
- (map
- (name: import (./. + "/${name}") pkgs oldpkgs)
- (filter
- (name: name != "default.nix" && !hasPrefix "." name)
- (attrNames (readDir ./.))))
+self: super:
- // {
- ReaktorPlugins = pkgs.callPackage ./simple/Reaktor/plugins.nix {};
+# Import files and subdirectories like they are overlays.
+foldl' mergeAttrs {}
+ (map
+ (name: import (./. + "/${name}") self super)
+ (filter
+ (name: name != "default.nix" && !hasPrefix "." name)
+ (attrNames (readDir ./.))))
- buildbot-full = pkgs.callPackage ./simple/buildbot {
- plugins = with pkgs.buildbot-plugins; [ www console-view waterfall-view ];
- };
- buildbot-worker = pkgs.callPackage ./simple/buildbot/worker.nix {};
+//
- # https://github.com/proot-me/PRoot/issues/106
- proot = pkgs.writeDashBin "proot" ''
- export PROOT_NO_SECCOMP=1
- exec ${oldpkgs.proot}/bin/proot "$@"
- '';
+{
+ ReaktorPlugins = self.callPackage ./simple/Reaktor/plugins.nix {};
- # XXX symlinkJoin changed arguments somewhere around nixpkgs d541e0d
- symlinkJoin = { name, paths, ... }@args: let
- x = oldpkgs.symlinkJoin args;
- in if typeOf x != "lambda" then x else oldpkgs.symlinkJoin name paths;
- }
+ buildbot-full = self.callPackage ./simple/buildbot {
+ plugins = with self.buildbot-plugins; [ www console-view waterfall-view ];
+ };
+ buildbot-worker = self.callPackage ./simple/buildbot/worker.nix {};
+
+ # https://github.com/proot-me/PRoot/issues/106
+ proot = self.writeDashBin "proot" ''
+ export PROOT_NO_SECCOMP=1
+ exec ${super.proot}/bin/proot "$@"
+ '';
+
+ # XXX symlinkJoin changed arguments somewhere around nixpkgs d541e0d
+ symlinkJoin = { name, paths, ... }@args: let
+ x = super.symlinkJoin args;
+ in if typeOf x != "lambda" then x else super.symlinkJoin name paths;
+}