summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-02-11 03:47:26 +0100
committertv <tv@krebsco.de>2016-02-11 03:47:26 +0100
commit0cf6d065f43c66efadd0a364c3414e6ecdae0004 (patch)
tree85b2af1878da06a7f1104e6f2d91439e179f2efc /krebs/5pkgs/default.nix
parent8b130a66287b829e7b6f9be0130df7231c7a6605 (diff)
*: turn 5pkgs into a(n optional) module
Diffstat (limited to 'krebs/5pkgs/default.nix')
-rw-r--r--krebs/5pkgs/default.nix50
1 files changed, 26 insertions, 24 deletions
diff --git a/krebs/5pkgs/default.nix b/krebs/5pkgs/default.nix
index 89e19dff..1cf3de56 100644
--- a/krebs/5pkgs/default.nix
+++ b/krebs/5pkgs/default.nix
@@ -1,31 +1,33 @@
{ lib, pkgs, ... }@args:
with lib;
{
- haskellPackages = pkgs.haskellPackages.override {
- overrides = self: super:
- mapAttrs (name: path: self.callPackage path {})
- (mapAttrs'
- (name: type:
- if hasSuffix ".nix" name
- then {
- name = removeSuffix ".nix" name;
- value = ./haskell-overrides + "/${name}";
- }
- else null)
- (builtins.readDir ./haskell-overrides));
- };
+ nixpkgs.config.packageOverrides = pkgs: {
+ haskellPackages = pkgs.haskellPackages.override {
+ overrides = self: super:
+ mapAttrs (name: path: self.callPackage path {})
+ (mapAttrs'
+ (name: type:
+ if hasSuffix ".nix" name
+ then {
+ name = removeSuffix ".nix" name;
+ value = ./haskell-overrides + "/${name}";
+ }
+ else null)
+ (builtins.readDir ./haskell-overrides));
+ };
- push = pkgs.callPackage ./push {
- inherit (subdirs) get jq;
- };
+ push = pkgs.callPackage ./push {
+ inherit (subdirs) get jq;
+ };
- ReaktorPlugins = pkgs.callPackage ./Reaktor/plugins.nix {};
+ ReaktorPlugins = pkgs.callPackage ./Reaktor/plugins.nix {};
- test = {
- infest-cac-centos7 = pkgs.callPackage ./test/infest-cac-centos7 {};
- };
+ test = {
+ infest-cac-centos7 = pkgs.callPackage ./test/infest-cac-centos7 {};
+ };
+ }
+ // import ./builders.nix args
+ // mapAttrs (_: flip pkgs.callPackage {})
+ (filterAttrs (_: dir.has-default-nix)
+ (subdirsOf ./.));
}
-// import ./builders.nix args
-// mapAttrs (_: flip pkgs.callPackage {})
- (filterAttrs (_: dir.has-default-nix)
- (subdirsOf ./.))