summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-11-15 23:26:55 +0100
committermakefu <github@syntax-fehler.de>2016-11-15 23:26:55 +0100
commit0155fc32e1b79bc25fdfc81ee8460438b70ba128 (patch)
tree6e6bc2b050a54699c98fdb945705e15d92ad0176 /krebs/5pkgs/default.nix
parent5de3acd2a0e35dcfb25ab893f5299e47a715427f (diff)
k 5: override buildbot
Diffstat (limited to 'krebs/5pkgs/default.nix')
-rw-r--r--krebs/5pkgs/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/krebs/5pkgs/default.nix b/krebs/5pkgs/default.nix
index 876f8b9a..c1ec0f33 100644
--- a/krebs/5pkgs/default.nix
+++ b/krebs/5pkgs/default.nix
@@ -38,6 +38,12 @@ with import <stockholm/lib>;
ReaktorPlugins = callPackage ./Reaktor/plugins.nix {};
+ buildbot = callPackage ./buildbot {};
+ buildbot-full = callPackage ./buildbot {
+ plugins = with pkgs.buildbot-plugins; [ www console-view waterfall-view ];
+ };
+ buildbot-worker = callPackage ./buildbot/worker.nix {};
+
# XXX symlinkJoin changed arguments somewhere around nixpkgs d541e0d
symlinkJoin = { name, paths, ... }@args: let
x = pkgs.symlinkJoin args;