summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/dns.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-28 21:38:22 +0200
committertv <tv@shackspace.de>2015-07-28 21:38:22 +0200
commit06cb4d25ef40773e2cc516e50a9aeec6cbe1d0a8 (patch)
treee05d849f048473aa9c90dc81b09d3a30dbe28ccc /krebs/4lib/dns.nix
parent060087fab989a2cf362928c471ac8fd9c4d95c1e (diff)
*/krebs -> krebs/*
Diffstat (limited to 'krebs/4lib/dns.nix')
-rw-r--r--krebs/4lib/dns.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/krebs/4lib/dns.nix b/krebs/4lib/dns.nix
new file mode 100644
index 00000000..b2cf3c24
--- /dev/null
+++ b/krebs/4lib/dns.nix
@@ -0,0 +1,31 @@
+{ lib, ... }:
+
+let
+ listset = import ./listset.nix { inherit lib; };
+in
+
+with builtins;
+with lib;
+
+rec {
+ # label = string
+
+ # TODO does it make sense to have alias = list label?
+
+ # split-by-provider :
+ # [[label]] -> tree label provider -> listset provider alias
+ split-by-provider = as: providers:
+ foldl (m: a: listset.insert (provider-of a providers) a m) {} as;
+
+ # provider-of : alias -> tree label provider -> provider
+ # Note that we cannot use tree.get here, because path can be longer
+ # than the tree depth.
+ provider-of = a:
+ let
+ go = path: tree:
+ if typeOf tree == "string"
+ then tree
+ else go (tail path) tree.${head path};
+ in
+ go (reverseList (splitString "." a));
+}