summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/users.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2022-11-23 16:37:32 +0100
committertv <tv@krebsco.de>2022-11-23 19:15:49 +0100
commitc084136980f9a29f5b42b32731b6dbe22b3366dc (patch)
tree295c1825214391886a551408f88159fc3ec515f0 /krebs/3modules/users.nix
parentb065ee81dc5e153d1f16a168db82b4eb7bfb2850 (diff)
krebs: extract users into separate module
Diffstat (limited to 'krebs/3modules/users.nix')
-rw-r--r--krebs/3modules/users.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/krebs/3modules/users.nix b/krebs/3modules/users.nix
new file mode 100644
index 00000000..c1ad4b44
--- /dev/null
+++ b/krebs/3modules/users.nix
@@ -0,0 +1,20 @@
+{ config, ... }: let
+ lib = import ../../lib;
+in {
+ options.krebs.users = lib.mkOption {
+ type = with lib.types; attrsOf user;
+ };
+ config = lib.mkIf config.krebs.enable {
+ krebs.users = {
+ krebs = {
+ home = "/krebs";
+ mail = "spam@krebsco.de";
+ };
+ root = {
+ home = "/root";
+ pubkey = config.krebs.build.host.ssh.pubkey;
+ uid = 0;
+ };
+ };
+ };
+}