summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/urlwatch.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-02-14 16:43:44 +0100
committertv <tv@krebsco.de>2016-02-14 16:43:44 +0100
commit673853e092c211e26a08030f87f9c868c6442a71 (patch)
treec71d2ac88a48cd74c37f03d1665e666030500d1d /krebs/3modules/urlwatch.nix
parent9f16d7ea71a2566b973ad0ac603c63ac3c6f4311 (diff)
RIP specialArgs.lib
Diffstat (limited to 'krebs/3modules/urlwatch.nix')
-rw-r--r--krebs/3modules/urlwatch.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/krebs/3modules/urlwatch.nix b/krebs/3modules/urlwatch.nix
index 7a9fb55f..cd4976a2 100644
--- a/krebs/3modules/urlwatch.nix
+++ b/krebs/3modules/urlwatch.nix
@@ -5,14 +5,14 @@
# cache = url: "${cfg.dataDir}/.urlwatch/cache/${hashString "sha1" url}"
# TODO hooks.py
-with lib;
+with config.krebs.lib;
let
cfg = config.krebs.urlwatch;
# TODO assert sendmail's existence
out = {
options.krebs.urlwatch = api;
- config = mkIf cfg.enable imp;
+ config = lib.mkIf cfg.enable imp;
};
api = {