summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/tinc_graphs.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-06-13 02:04:22 +0200
committertv <tv@krebsco.de>2016-06-13 02:10:02 +0200
commita16f4383142403eab145a8d147e5c9c93309ba4f (patch)
tree160727b414ea864b2a5018e940952ff10c95f3af /krebs/3modules/tinc_graphs.nix
parentfb226f349843c080d6c81b60301a3a93977b99a4 (diff)
sprinkle with some write{B,D}ash
Diffstat (limited to 'krebs/3modules/tinc_graphs.nix')
-rw-r--r--krebs/3modules/tinc_graphs.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/krebs/3modules/tinc_graphs.nix b/krebs/3modules/tinc_graphs.nix
index 2692de98..dec89d24 100644
--- a/krebs/3modules/tinc_graphs.nix
+++ b/krebs/3modules/tinc_graphs.nix
@@ -94,8 +94,7 @@ let
TimeoutSec = 300; # we will wait 5 minutes, kill otherwise
restart = "always";
- ExecStartPre = pkgs.writeScript "tinc_graphs-init" ''
- #!/bin/sh
+ ExecStartPre = pkgs.writeDash "tinc_graphs-init" ''
mkdir -p "${internal_dir}" "${external_dir}"
if ! test -e "${cfg.workingDir}/internal/index.html"; then
cp -fr "$(${pkgs.tinc_graphs}/bin/tincstats-static-dir)/internal/." "${internal_dir}"
@@ -106,8 +105,7 @@ let
'';
ExecStart = "${pkgs.tinc_graphs}/bin/all-the-graphs";
- ExecStartPost = pkgs.writeScript "tinc_graphs-post" ''
- #!/bin/sh
+ ExecStartPost = pkgs.writeDash "tinc_graphs-post" ''
# TODO: this may break if workingDir is set to something stupid
# this is needed because homedir is created with 700
chmod 755 "${cfg.workingDir}"