summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/tinc_graphs.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-10-25 21:54:59 +0100
committermakefu <github@syntax-fehler.de>2015-10-25 21:54:59 +0100
commit642583145200f5a2cb8be1b38707e2b2ea3dc3e5 (patch)
tree6a603b63e9d4ea30545348816de2880369e76927 /krebs/3modules/tinc_graphs.nix
parentbb16a38df6ad33c7339d4875e948853927015045 (diff)
k 3 tinc_graphs: is now completely self-contained
Diffstat (limited to 'krebs/3modules/tinc_graphs.nix')
-rw-r--r--krebs/3modules/tinc_graphs.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/krebs/3modules/tinc_graphs.nix b/krebs/3modules/tinc_graphs.nix
index a6c62835..e415d20a 100644
--- a/krebs/3modules/tinc_graphs.nix
+++ b/krebs/3modules/tinc_graphs.nix
@@ -95,8 +95,12 @@ let
ExecStartPre = pkgs.writeScript "tinc_graphs-init" ''
#!/bin/sh
+ mkdir -p "${internal_dir}" "${external_dir}"
if ! test -e "${cfg.workingDir}/internal/index.html"; then
- cp -fr "$(${pkgs.tinc_graphs}/bin/tincstats-static-dir)/internal/" "${internal_dir}"
+ cp -fr "$(${pkgs.tinc_graphs}/bin/tincstats-static-dir)/internal/." "${internal_dir}"
+ fi
+ if ! test -e "${cfg.workingDir}/external/index.html"; then
+ cp -fr "$(${pkgs.tinc_graphs}/bin/tincstats-static-dir)/external/." "${external_dir}"
fi
'';
@@ -118,7 +122,6 @@ let
users.extraUsers.tinc_graphs = {
uid = 3925439960; #genid tinc_graphs
home = "/var/spool/tinc_graphs";
- createHome = true;
};
krebs.nginx.servers = mkIf cfg.nginx.enable {