summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/tinc.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2023-01-23 18:44:56 +0100
committertv <tv@krebsco.de>2023-01-23 18:49:59 +0100
commitebd22b2d282d3b718f173a243615d954e00254e9 (patch)
tree16a7d8c53ae446f67ff6c857178b0dcb52e1282e /krebs/3modules/tinc.nix
parentc8c916ccf1a95f0e755094fd3d24403af91a0b67 (diff)
tinc: drop tincUpExtra
Diffstat (limited to 'krebs/3modules/tinc.nix')
-rw-r--r--krebs/3modules/tinc.nix10
1 files changed, 1 insertions, 9 deletions
diff --git a/krebs/3modules/tinc.nix b/krebs/3modules/tinc.nix
index 4afd0a3a..52cdafe6 100644
--- a/krebs/3modules/tinc.nix
+++ b/krebs/3modules/tinc.nix
@@ -26,10 +26,7 @@ with import <stockholm/lib>;
Port = ${toString tinc.config.host.nets.${netname}.tinc.port}
${tinc.config.extraConfig}
'';
- "tinc-up" = pkgs.writeDash "${netname}-tinc-up" /* sh */ ''
- ${tinc.config.tincUp}
- ${tinc.config.tincUpExtra}
- '';
+ "tinc-up" = pkgs.writeDash "${netname}-tinc-up" tinc.config.tincUp;
});
};
@@ -85,11 +82,6 @@ with import <stockholm/lib>;
'';
};
- tincUpExtra = mkOption {
- type = types.str;
- default = "";
- };
-
tincPackage = mkOption {
type = types.package;
default = pkgs.tinc_pre;