summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/tinc.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-10-03 18:40:44 +0200
committerlassulus <lassulus@lassul.us>2017-10-03 18:40:44 +0200
commit902a65304d1e07ce5a7192a0403d6fa1bed1f135 (patch)
tree4a17d1004bc6bd2f913360ad2325856e3beed894 /krebs/3modules/tinc.nix
parentc37c047ee6c080f7d76f2e19269162615a9aacfb (diff)
tinc module: workaround nixpkgs's lib.types.types
Introduced by nixpkgs 152c63c9ff82276e225ac4a4fa71c791d33e443d
Diffstat (limited to 'krebs/3modules/tinc.nix')
-rw-r--r--krebs/3modules/tinc.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/krebs/3modules/tinc.nix b/krebs/3modules/tinc.nix
index 0fd0a35b..b032f314 100644
--- a/krebs/3modules/tinc.nix
+++ b/krebs/3modules/tinc.nix
@@ -1,7 +1,6 @@
-{ config, pkgs, lib, ... }:
with import <stockholm/lib>;
+{ config, pkgs, ... }:
let
- inherit (import <stockholm/lib>) types;
out = {
options.krebs.tinc = api;
config = imp;
@@ -12,7 +11,7 @@ let
description = ''
define a tinc network
'';
- type = with types; attrsOf (submodule (tinc: {
+ type = types.attrsOf (types.submodule (tinc: {
options = let
netname = tinc.config._module.args.name;
in {
@@ -117,7 +116,7 @@ let
phases = [ "installPhase" ];
installPhase = ''
mkdir $out
- ${concatStrings (lib.mapAttrsToList (_: host: ''
+ ${concatStrings (mapAttrsToList (_: host: ''
echo ${shell.escape host.nets."${tinc.config.netname}".tinc.config} \
> $out/${shell.escape host.name}
'') tinc.config.hosts)}