summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/tinc.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2021-12-23 03:16:44 +0100
committertv <tv@krebsco.de>2021-12-23 03:16:44 +0100
commit8029e80632da0dcb886445bd1e9ba2d55821cc30 (patch)
tree71cd70a6375314f3e56b6154b41cf6fb98fbe5e4 /krebs/3modules/tinc.nix
parent018018e16b95b45f4a086df48c10a102a34e79ba (diff)
krebs.tinc: drop api and imp boilerplate
Diffstat (limited to 'krebs/3modules/tinc.nix')
-rw-r--r--krebs/3modules/tinc.nix14
1 files changed, 4 insertions, 10 deletions
diff --git a/krebs/3modules/tinc.nix b/krebs/3modules/tinc.nix
index 2daef8e1..91aa37fd 100644
--- a/krebs/3modules/tinc.nix
+++ b/krebs/3modules/tinc.nix
@@ -1,12 +1,6 @@
with import <stockholm/lib>;
-{ config, pkgs, ... }:
-let
- out = {
- options.krebs.tinc = api;
- config = imp;
- };
-
- api = mkOption {
+{ config, pkgs, ... }: {
+ options.krebs.tinc = mkOption {
default = {};
description = ''
define a tinc network
@@ -214,7 +208,7 @@ let
}));
};
- imp = {
+ config = {
# TODO `environment.systemPackages = [ cfg.tincPackage cfg.iproutePackage ]` for each network,
# avoid conflicts in environment if the packages differ
@@ -272,4 +266,4 @@ let
};
}) config.krebs.tinc;
};
-in out
+}