summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/rtorrent.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-01-09 15:57:32 +0100
committermakefu <github@syntax-fehler.de>2017-01-09 15:57:32 +0100
commitb1b24e475939fced39d0d3db4801bd4c9174b042 (patch)
tree7f0b8b17d9ab1bc6bd99c2702775ceaf0b9cfe4a /krebs/3modules/rtorrent.nix
parentc22c74b05d0da8febe1fbeec0808f7b66f3920fc (diff)
k 3 rtorrent: always restart
on-failure does not seem to be enough to save it from crashing
Diffstat (limited to 'krebs/3modules/rtorrent.nix')
-rw-r--r--krebs/3modules/rtorrent.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/krebs/3modules/rtorrent.nix b/krebs/3modules/rtorrent.nix
index 0c478ade..d8551899 100644
--- a/krebs/3modules/rtorrent.nix
+++ b/krebs/3modules/rtorrent.nix
@@ -224,13 +224,14 @@ let
cp -f ${configFile} ${cfg.workDir}/.rtorrent.rc
'';
ExecStart = "${pkgs.tmux}/bin/tmux new-session -s rt -n rtorrent -d 'PATH=/bin:/usr/bin:${makeBinPath rutorrent-deps} ${cfg.package}/bin/rtorrent'";
+ Restart = "always";
+ RestartSec = "10";
## you can simply sudo -u rtorrent tmux a if privateTmp is set to false
## otherwise the tmux session is stored in some private folder in /tmp
PrivateTmp = false;
WorkingDirectory = cfg.workDir;
- Restart = "on-failure";
User = "${cfg.user}";
};
};