summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/repo-sync.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-09-07 15:52:37 +0200
committermakefu <github@syntax-fehler.de>2016-09-07 15:52:37 +0200
commit71b41a206e22b8cf07e219028b4f365db2f765f0 (patch)
treed42db221be3e524a10d77ca2616ce5e6536c3810 /krebs/3modules/repo-sync.nix
parent907499c10bd4063cd4649899b959edd503743ee7 (diff)
k 3 repo-sync: add more explicit documentation
Diffstat (limited to 'krebs/3modules/repo-sync.nix')
-rw-r--r--krebs/3modules/repo-sync.nix40
1 files changed, 34 insertions, 6 deletions
diff --git a/krebs/3modules/repo-sync.nix b/krebs/3modules/repo-sync.nix
index 0317d1ec..bcd9da5e 100644
--- a/krebs/3modules/repo-sync.nix
+++ b/krebs/3modules/repo-sync.nix
@@ -17,29 +17,57 @@ let
# see `repo-sync --help`
# `ref` provides sane defaults and can be omitted
+ # you can have multiple repo-sync groups and therefore multiple @latest
+ # configuration entries.
# attrset will be converted to json and be used as config
- { repo = {
+ # each attrset defines a group of repos for syncing
+
+ { nxpkgs = {
makefu = {
origin = {
- url = http://github.com/makefu/repo ;
+ url = http://github.com/makefu/nixpkgs;
ref = "heads/dev" ;
};
mirror = {
- url = "git@internal:mirror" ;
+ url = "git@internal:nixpkgs-mirror" ;
ref = "heads/github-mirror-dev" ;
};
};
lass = {
origin = {
- url = http://github.com/lass/repo ;
+ url = http://github.com/lass/nixpkgs;
+ };
+ mirror = {
+ url = "git@internal:nixpkgs-mirror" ;
+ };
+ };
+ "@latest" = {
+ mirror = {
+ url = "git@internal:nixpkgs-mirror";
+ ref = "heads/master";
+ };
+ };
+ };
+ stockholm = {
+ lass = {
+ origin = {
+ url = http://cgit.prism.r/stockholm;
+ };
+ mirror = {
+ url = "git@internal:stockholm-mirror" ;
+ };
+ };
+ makefu = {
+ origin = {
+ url = http://gum.krebsco.de/stockholm;
};
mirror = {
- url = "git@internal:mirror" ;
+ url = "git@internal:stockholm-mirror" ;
};
};
"@latest" = {
mirror = {
- url = "git@internal:mirror";
+ url = "git@internal:stockholm-mirror";
ref = "heads/master";
};
};