summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/repo-sync.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-02-28 14:30:11 +0100
committertv <tv@krebsco.de>2018-02-28 15:15:58 +0100
commit3ac7941968e20ebaf553a7e44f8dbfb990de4eb1 (patch)
tree74b9204b22961de1a8c881e4c186faebfe7465f6 /krebs/3modules/repo-sync.nix
parent34e88f9cef87c582fb7d88e90e5a96cb28a61188 (diff)
types: refactor source
Diffstat (limited to 'krebs/3modules/repo-sync.nix')
-rw-r--r--krebs/3modules/repo-sync.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/krebs/3modules/repo-sync.nix b/krebs/3modules/repo-sync.nix
index b2e3aa7c..45d9d81c 100644
--- a/krebs/3modules/repo-sync.nix
+++ b/krebs/3modules/repo-sync.nix
@@ -18,10 +18,10 @@ let
type = types.attrsOf (types.submodule ({ config, ... }: {
options = {
origin = mkOption {
- type = types.git-source;
+ type = types.source-types.git;
};
mirror = mkOption {
- type = types.git-source;
+ type = types.source-types.git;
};
};
config = {
@@ -31,7 +31,7 @@ let
}));
};
latest = mkOption {
- type = types.nullOr types.git-source;
+ type = types.nullOr types.source-types.git;
default = null;
};
timerConfig = mkOption {