summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/repo-sync.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-06-26 17:53:11 +0200
committerlassulus <lass@aidsballs.de>2016-06-26 17:53:11 +0200
commit16b639e50ad2c2cbf33a545f244fb65d28e2f292 (patch)
treeeb3599bde83c20473e722883d343ce015d58fd9e /krebs/3modules/repo-sync.nix
parentfe07d46310e3320161f9c82e021f200ed02fbadf (diff)
k 3 repo-sync: add unitConfig option
Diffstat (limited to 'krebs/3modules/repo-sync.nix')
-rw-r--r--krebs/3modules/repo-sync.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/krebs/3modules/repo-sync.nix b/krebs/3modules/repo-sync.nix
index 3f251525..0725d18f 100644
--- a/krebs/3modules/repo-sync.nix
+++ b/krebs/3modules/repo-sync.nix
@@ -75,6 +75,16 @@ let
};
};
+ unitConfig = mkOption {
+ type = types.attrsOf types.str;
+ description = "Extra unit configuration for fetchWallpaper to define conditions and assertions for the unit";
+ example = literalExample ''
+ # do not start when running on umts
+ { ConditionPathExists = "!/var/run/ppp0.pid"; }
+ '';
+ default = {};
+ };
+
};
imp = {
@@ -113,6 +123,7 @@ let
WorkingDirectory = cfg.stateDir;
User = "repo-sync";
};
+ unitConfig = cfg.unitConfig;
}
) cfg.repos;
};