summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/realwallpaper.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-04-15 17:13:40 +0200
committerlassulus <lass@lassul.us>2017-04-15 17:14:34 +0200
commita80cbaa6e962ea6dcdbf4c01f7e1188ac71c631f (patch)
treef7da091c42e78ae205afcc9b4766bfb7800ee977 /krebs/3modules/realwallpaper.nix
parent48d37be5dea8c74c929bd23153361f3cf419f43e (diff)
realwallpaper: introduce marker_file
Diffstat (limited to 'krebs/3modules/realwallpaper.nix')
-rw-r--r--krebs/3modules/realwallpaper.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/krebs/3modules/realwallpaper.nix b/krebs/3modules/realwallpaper.nix
index f9eae8c9..1e7a9faa 100644
--- a/krebs/3modules/realwallpaper.nix
+++ b/krebs/3modules/realwallpaper.nix
@@ -32,9 +32,9 @@ let
default = "http://xplanetclouds.com/free/local/clouds_2048.jpg";
};
- outFile = mkOption {
+ marker = mkOption {
type = types.str;
- default = "/tmp/wallpaper.png";
+ default = "http://graphs.r/marker.json";
};
timerConfig = mkOption {
@@ -43,7 +43,6 @@ let
OnCalendar = "*:0/15";
};
};
-
};
imp = {
@@ -63,6 +62,7 @@ let
imagemagick
curl
file
+ jq
];
environment = {
@@ -70,7 +70,7 @@ let
nightmap_url = cfg.nightmap;
daymap_url = cfg.daymap;
cloudmap_url = cfg.cloudmap;
- out_file = cfg.outFile;
+ marker_url = cfg.marker;
};
restartIfChanged = true;