summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/git.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-06-07 03:11:26 +0200
committertv <tv@krebsco.de>2016-06-07 03:11:26 +0200
commitb5bdd9aed4530924bca3d515eedeed215cfd64c2 (patch)
tree732a09b46f7013d00c05aab335ba8bce94896f64 /krebs/3modules/git.nix
parent39ebd5001ebcbcc9d991784ec1ce6dd804dbdcd4 (diff)
krebs.git.cgit :: { bool => submodule { enable :: bool } }
Diffstat (limited to 'krebs/3modules/git.nix')
-rw-r--r--krebs/3modules/git.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/krebs/3modules/git.nix b/krebs/3modules/git.nix
index d2d73ba3..542f1f38 100644
--- a/krebs/3modules/git.nix
+++ b/krebs/3modules/git.nix
@@ -13,7 +13,7 @@ let
out = {
options.krebs.git = api;
config = with lib; mkIf cfg.enable (mkMerge [
- (mkIf cfg.cgit cgit-imp)
+ (mkIf cfg.cgit.enable cgit-imp)
git-imp
]);
};
@@ -22,10 +22,13 @@ let
enable = mkEnableOption "krebs.git";
cgit = mkOption {
- type = types.bool;
- default = true;
+ type = types.submodule {
+ options = {
+ enable = mkEnableOption "krebs.git.cgit" // { default = true; };
+ };
+ };
+ default = {};
description = ''
- Enable cgit.
Cgit is an attempt to create a fast web interface for the git version
control system, using a built in cache to decrease pressure on the
git server.