summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/git.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-09-19 11:30:57 +0200
committerlassulus <lassulus@lassul.us>2017-09-19 11:30:57 +0200
commit797535fc1ff1dd88239e06ecee861d228107c6e9 (patch)
treed5b48e6b7cdbb502e92ce0f62b30545c26783882 /krebs/3modules/git.nix
parent9eff836daa6f6ddf75882d19fe76dec36de38d49 (diff)
git: add repo.admins option
Diffstat (limited to 'krebs/3modules/git.nix')
-rw-r--r--krebs/3modules/git.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/krebs/3modules/git.nix b/krebs/3modules/git.nix
index 93211d9d..610c20bb 100644
--- a/krebs/3modules/git.nix
+++ b/krebs/3modules/git.nix
@@ -186,6 +186,17 @@ let
};
repo = types.submodule ({ config, ... }: {
options = {
+ admins = mkOption {
+ type = types.listOf types.user;
+ default = [];
+ description = ''
+ List of users that should be able to do everything with this repo.
+
+ This option is currently not used by krebs.git but instead can be
+ used to create rules. See e.g. <stockholm/lass/2configs/git.nix> for
+ an example.
+ '';
+ };
cgit = {
desc = mkOption {
type = types.nullOr types.str;