summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/git.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-02-14 16:43:44 +0100
committertv <tv@krebsco.de>2016-02-14 16:43:44 +0100
commit673853e092c211e26a08030f87f9c868c6442a71 (patch)
treec71d2ac88a48cd74c37f03d1665e666030500d1d /krebs/3modules/git.nix
parent9f16d7ea71a2566b973ad0ac603c63ac3c6f4311 (diff)
RIP specialArgs.lib
Diffstat (limited to 'krebs/3modules/git.nix')
-rw-r--r--krebs/3modules/git.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/krebs/3modules/git.nix b/krebs/3modules/git.nix
index 11cf21b5..a9542718 100644
--- a/krebs/3modules/git.nix
+++ b/krebs/3modules/git.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, lib, ... }:
+{ config, lib, pkgs, ... }:
# TODO unify logging of shell scripts to user and journal
# TODO move all scripts to ${etcDir}, so ControlMaster connections
@@ -6,13 +6,13 @@
# TODO when authorized_keys changes, then restart ssh
# (or kill already connected users somehow)
-with lib;
+with config.krebs.lib;
let
cfg = config.krebs.git;
out = {
options.krebs.git = api;
- config = mkIf cfg.enable (mkMerge [
+ config = with lib; mkIf cfg.enable (mkMerge [
(mkIf cfg.cgit cgit-imp)
git-imp
]);
@@ -86,7 +86,7 @@ let
singleton {
user = [ config.krebs.users.tv ];
repo = [ testing ]; # see literal example of repos
- perm = push "refs/*" (with lib.git; [
+ perm = push "refs/*" (with config.krebs.lib.git; [
non-fast-forward create delete merge
]);
}