summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/git.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2021-11-08 09:06:57 +0100
committerlassulus <lassulus@lassul.us>2021-11-08 09:06:57 +0100
commit4452b26816fa10269f0ab850467c0feff87f64d8 (patch)
tree7d5c939254ae2308d557296b4ebdb695cdc754f4 /krebs/3modules/git.nix
parent0e668121a1388914f33a6546c2f63adc212a38c4 (diff)
parentc979f7009f5ff1b2d25158aff1bca0f5be2dba54 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'krebs/3modules/git.nix')
-rw-r--r--krebs/3modules/git.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/krebs/3modules/git.nix b/krebs/3modules/git.nix
index 0aa1ae0f..1bfd58e3 100644
--- a/krebs/3modules/git.nix
+++ b/krebs/3modules/git.nix
@@ -53,7 +53,7 @@ let
control system, using a built in cache to decrease pressure on the
git server.
cgit in this module is being served via fastcgi nginx.This module
- deploys a http://cgit.<hostname> nginx configuration and enables nginx
+ deploys a http://cgit.‹hostname› nginx configuration and enables nginx
if not yet enabled.
'';
};
@@ -207,7 +207,7 @@ let
List of users that should be able to do everything with this repo.
This option is currently not used by krebs.git but instead can be
- used to create rules. See e.g. <stockholm/lass/2configs/git.nix> for
+ used to create rules. See e.g. ‹stockholm/lass/2configs/git.nix› for
an example.
'';
};
@@ -222,6 +222,7 @@ let
path = mkOption {
type = types.str;
default = "${cfg.dataDir}/${config.name}";
+ defaultText = "${cfg.dataDir}/‹reponame›";
description = ''
An absolute path to the repository directory. For non-bare
repositories this is the .git-directory.
@@ -237,6 +238,7 @@ let
url = mkOption {
type = types.str;
default = config.name;
+ defaultText = "‹reponame›";
description = ''
The relative url used to access the repository.
'';
@@ -249,7 +251,7 @@ let
List of users that should be able to fetch from this repo.
This option is currently not used by krebs.git but instead can be
- used to create rules. See e.g. <stockholm/tv/2configs/git.nix> for
+ used to create rules. See e.g. ‹stockholm/tv/2configs/git.nix› for
an example.
'';
};
@@ -258,6 +260,7 @@ let
description = ''
Repository name.
'';
+ defaultText = "‹reponame›";
};
hooks = mkOption {
type = types.attrsOf types.str;