summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/dns.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2022-12-02 08:29:40 +0100
committerlassulus <lassulus@lassul.us>2022-12-02 08:29:40 +0100
commit2ea3b14cb5caa06f2d2972177a93cddb6d9d66f6 (patch)
tree84b86d77b88868fc70082a64f35b5077247157dd /krebs/3modules/dns.nix
parent81b5682c5ff1e36613f844a874e09b897ee13d3e (diff)
parentf8fb430fc1bbc3ee6356971bbd1bdeba1b9a0d69 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'krebs/3modules/dns.nix')
-rw-r--r--krebs/3modules/dns.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/krebs/3modules/dns.nix b/krebs/3modules/dns.nix
index 8acc4ccd..8a74d306 100644
--- a/krebs/3modules/dns.nix
+++ b/krebs/3modules/dns.nix
@@ -1,12 +1,21 @@
with import <stockholm/lib>;
-{
+{ config, ... }: {
options = {
krebs.dns.providers = mkOption {
type = types.attrsOf types.str;
};
-
krebs.dns.search-domain = mkOption {
type = types.nullOr types.hostname;
};
};
+ config = mkIf config.krebs.enable {
+ krebs.dns.providers = {
+ "krebsco.de" = "zones";
+ shack = "hosts";
+ i = "hosts";
+ r = "hosts";
+ w = "hosts";
+ };
+ krebs.dns.search-domain = mkDefault "r";
+ };
}