summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/ci.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-08-31 19:01:53 +0200
committerlassulus <lassulus@lassul.us>2017-08-31 19:01:53 +0200
commit0bde01ddff0842122d17f886d7690c1dc9fc500a (patch)
tree228168619a001a33207b301613bebcdd48427ec7 /krebs/3modules/ci.nix
parent522f6c03cfaada59e4c571a735b5022acbc31c18 (diff)
ci: replace users by hosts
Diffstat (limited to 'krebs/3modules/ci.nix')
-rw-r--r--krebs/3modules/ci.nix50
1 files changed, 9 insertions, 41 deletions
diff --git a/krebs/3modules/ci.nix b/krebs/3modules/ci.nix
index b55827e3..dab87792 100644
--- a/krebs/3modules/ci.nix
+++ b/krebs/3modules/ci.nix
@@ -17,30 +17,12 @@ in
default = 10;
description = "how long to wait until we test changes (in minutes)";
};
- users = mkOption {
- type = with types; attrsOf (submodule {
- options = {
- all = mkOption {
- type = bool;
- default = false;
- };
- hosts = mkOption {
- type = listOf str;
- default = [];
- };
- };
- });
- example = {
- lass.all = true;
- krebs = {
- all = true;
- hosts = [
- "test-all-krebs-modules"
- "test-arch"
- ];
- };
- };
- default = {};
+ hosts = mkOption {
+ type = types.listOf types.host;
+ default = [];
+ description = ''
+ List of hosts that should be build
+ '';
};
};
@@ -132,23 +114,9 @@ in
timeout=90001
)
- ${let
- user-hosts = mapAttrs (user: a: let
- managed-hosts = attrNames (filterAttrs (_: h: (h.owner.name == user) && h.managed) config.krebs.hosts);
- defined-hosts = a.hosts;
- in
- defined-hosts ++ (optionals a.all managed-hosts)
- ) cfg.users;
-
- in
- concatStringsSep "\n" (
- (mapAttrsToList (user: hosts:
- concatMapStringsSep "\n" (host:
- "build_host(\"${user}\", \"${host}\")"
- ) hosts
- ) user-hosts)
- )
- }
+ ${concatMapStringsSep "\n" (host:
+ "build_host(\"${host.owner.name}\", \"${host.name}\")"
+ ) cfg.hosts}
bu.append(
util.BuilderConfig(