summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/ci.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-08-09 18:14:04 +0200
committerlassulus <lassulus@lassul.us>2017-08-10 12:54:05 +0200
commit023bc5257a39ea1fe5644cd9d1561c1263bc03ac (patch)
treeef827efc8325e438429a4655318106a72d832801 /krebs/3modules/ci.nix
parent3addbef06bef297f6e15ebcd596b16f8862ad528 (diff)
ci: add stockholmSrc option
Diffstat (limited to 'krebs/3modules/ci.nix')
-rw-r--r--krebs/3modules/ci.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/krebs/3modules/ci.nix b/krebs/3modules/ci.nix
index 71e7d4ae..b55827e3 100644
--- a/krebs/3modules/ci.nix
+++ b/krebs/3modules/ci.nix
@@ -8,6 +8,10 @@ in
{
options.krebs.ci = {
enable = mkEnableOption "krebs continous integration";
+ stockholmSrc = mkOption {
+ type = types.str;
+ default = "http://cgit.${hostname}.r/stockholm";
+ };
treeStableTimer = mkOption {
type = types.int;
default = 10;
@@ -58,7 +62,7 @@ in
testslave = "lasspass";
};
change_source.stockholm = ''
- stockholm_repo = 'http://cgit.${hostname}.r/stockholm'
+ stockholm_repo = '${cfg.stockholmSrc}'
cs.append(
changes.GitPoller(
stockholm_repo,