summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/cachecache.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-12-03 09:20:14 +0100
committermakefu <github@syntax-fehler.de>2018-12-03 09:20:14 +0100
commit5782a4de2e5b5f4843a421bac7456e83790950d1 (patch)
tree9f8648d279419d03a20b5d14adca948c4f6a4834 /krebs/3modules/cachecache.nix
parentb8db7293383772b936b6937cc05b5588021ca693 (diff)
cache.nixos.org: provide index.html
Diffstat (limited to 'krebs/3modules/cachecache.nix')
-rw-r--r--krebs/3modules/cachecache.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/krebs/3modules/cachecache.nix b/krebs/3modules/cachecache.nix
index 98932048..2c2d07ff 100644
--- a/krebs/3modules/cachecache.nix
+++ b/krebs/3modules/cachecache.nix
@@ -1,4 +1,4 @@
-{ config, lib, ... }:
+{ pkgs, config, lib, ... }:
# fork of https://gist.github.com/rycee/f495fc6cc4130f155e8b670609a1e57b
@@ -59,15 +59,6 @@ in
'';
};
- # webRoot = mkOption {
- # type = types.str;
- # default = "/";
- # description = ''
- # Directory on virtual host that serves the cache. Must end in
- # <literal>/</literal>.
- # '';
- # };
-
resolver = mkOption {
type = types.str;
description = "Address of DNS resolver.";
@@ -82,6 +73,13 @@ in
Where nginx should store cached data.
'';
};
+ indexFile = mkOption {
+ type = types.path;
+ default = pkgs.writeText "myindex" "<html>hello world</html>";
+ description = ''
+ Path to index.html file.
+ '';
+ };
maxSize = mkOption {
type = types.str;
@@ -98,6 +96,7 @@ in
systemd.services.nginx.preStart = ''
mkdir -p ${cfg.cacheDir} /srv/www/nix-cache-cache
chmod 700 ${cfg.cacheDir} /srv/www/nix-cache-cache
+ ln -fs ${cfg.indexFile} /srv/www/nix-cache-cache/index.html
chown ${nginxCfg.user}:${nginxCfg.group} \
${cfg.cacheDir} /srv/www/nix-cache-cache
'';
@@ -143,6 +142,7 @@ in
locations."/" =
{
root = "/srv/www/nix-cache-cache";
+ index = "index.html";
extraConfig = ''
expires max;
add_header Cache-Control $nix_cache_cache_header always;