summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/Reaktor.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-09-04 22:56:06 +0200
committermakefu <github@syntax-fehler.de>2015-09-04 22:56:15 +0200
commitd12e86c48129ec497b0cba5743928be9bc2f3ae8 (patch)
tree0e2377810521f93b639a557b104e15b7ddd095cf /krebs/3modules/Reaktor.nix
parent8012e60b7778fa8addbf2e63a408dd20f0a80185 (diff)
Reaktor: debug enable/disable
Diffstat (limited to 'krebs/3modules/Reaktor.nix')
-rw-r--r--krebs/3modules/Reaktor.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/krebs/3modules/Reaktor.nix b/krebs/3modules/Reaktor.nix
index 7d9bad40..23a1c088 100644
--- a/krebs/3modules/Reaktor.nix
+++ b/krebs/3modules/Reaktor.nix
@@ -40,7 +40,7 @@ let
nickname = mkOption {
default = config.krebs.build.host.name + "|r";
- type = types.str;
+ type = types.string;
description = ''
The nick name of the irc bot.
Defaults to {hostname}|r
@@ -70,6 +70,12 @@ let
the Reaktor pkg to use.
'';
};
+ debug = mkOption {
+ default = false;
+ description = ''
+ Reaktor debug output
+ '';
+ };
};
imp = {
@@ -101,6 +107,7 @@ let
environment = {
GIT_SSL_CAINFO = "${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt";
REAKTOR_NICKNAME = cfg.nickname;
+ REAKTOR_DEBUG = (if cfg.debug then "True" else "False");
};
serviceConfig= {
ExecStartPre = pkgs.writeScript "Reaktor-init" ''