summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/wiki.nix
diff options
context:
space:
mode:
authorlassulus <git@lassul.us>2023-06-21 16:01:33 +0200
committerlassulus <git@lassul.us>2023-06-21 16:01:33 +0200
commita0c4427c0baa94603fa10c1248944e7837e72642 (patch)
treecaa4053366d62b683e6f6e746e9df0317de88c80 /krebs/2configs/wiki.nix
parentc6593fdb393a585e631b9824e2bb3857ba2f90c6 (diff)
parentfdc364520238a38883d28bbfa05ac966e792ed8b (diff)
Merge remote-tracking branch 'ni/flakify'
Diffstat (limited to 'krebs/2configs/wiki.nix')
-rw-r--r--krebs/2configs/wiki.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/krebs/2configs/wiki.nix b/krebs/2configs/wiki.nix
index 40d946f7..a227ceb4 100644
--- a/krebs/2configs/wiki.nix
+++ b/krebs/2configs/wiki.nix
@@ -1,5 +1,5 @@
-{ config, pkgs, ... }:
-with import <stockholm/lib>;
+{ config, lib, pkgs, ... }:
+with import ../../lib/pure.nix { inherit lib; };
let
setupGit = ''
@@ -14,13 +14,13 @@ let
fi
'';
- pushGollum = pkgs.writeDash "push_gollum" ''
+ pushGollum = pkgs.writers.writeDash "push_gollum" ''
${setupGit}
git fetch origin
git merge --ff-only origin/master
'';
- pushCgit = pkgs.writeDash "push_cgit" ''
+ pushCgit = pkgs.writers.writeDash "push_cgit" ''
${setupGit}
git push origin master
'';