summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/wiki.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2020-08-12 20:49:54 +0200
committerlassulus <lassulus@lassul.us>2020-08-12 20:49:54 +0200
commit514ba4d303e663529f347d5c3adbaece0f94361b (patch)
tree97968198e0cc7a18c3d3bdfe34cfda8bb5884ce4 /krebs/2configs/wiki.nix
parent19cc72be381b5718af90418cff45635f94a2012a (diff)
wiki: rename repo to wiki
Diffstat (limited to 'krebs/2configs/wiki.nix')
-rw-r--r--krebs/2configs/wiki.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/krebs/2configs/wiki.nix b/krebs/2configs/wiki.nix
index dc6de2ef..ad88d666 100644
--- a/krebs/2configs/wiki.nix
+++ b/krebs/2configs/wiki.nix
@@ -6,14 +6,15 @@ with import <stockholm/lib>;
enable = true;
extraConfig = ''
Gollum::Hook.register(:post_commit, :hook_id) do |committer, sha1|
- system('${toString (pkgs.writers.writeDash "debuglol" ''
+ system('${toString (pkgs.writers.writeDash "push_cgit" ''
export PATH=${makeBinPath [ pkgs.git ]}
export GIT_SSH_COMMAND='${pkgs.openssh}/bin/ssh -i ${config.krebs.gollum.stateDir}/.ssh/id_ed25519'
+ repo='git@localhost:wiki'
cd ${config.krebs.gollum.stateDir}
if ! url=$(git config remote.origin.url); then
- git remote add origin git@localhost:gollum
- elif test "$url" != 'git@localhost:gollum'; then
- git remote set-url origin git@localhost:gollum
+ git remote add origin "$repo"
+ elif test "$url" != "$repo"; then
+ git remote set-url origin "$repo"
fi
git push origin master
'')}')
@@ -48,13 +49,13 @@ with import <stockholm/lib>;
}
config.krebs.users.lass-mors
];
- repo = [ config.krebs.git.repos.gollum ];
+ repo = [ config.krebs.git.repos.wiki ];
perm = push ''refs/*'' [ create merge ];
}
];
- repos.gollum = {
+ repos.wiki = {
public = true;
- name = "gollum";
+ name = "wiki";
hooks = {
post-receive = pkgs.git-hooks.irc-announce {
channel = "#xxx";