summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/worlddomination.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-05-03 18:43:59 +0200
committermakefu <github@syntax-fehler.de>2018-05-03 18:43:59 +0200
commit45377068c0bfbb009b7cbe41dbca97dd44c9c955 (patch)
treea4a0d71464af08b4dae2cef68f031dbd0a8871b4 /krebs/2configs/shack/worlddomination.nix
parent82d5bca54179221759eb59f5bf10975b5261b1e3 (diff)
k worlddomination: deploy africa
Diffstat (limited to 'krebs/2configs/shack/worlddomination.nix')
-rw-r--r--krebs/2configs/shack/worlddomination.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/krebs/2configs/shack/worlddomination.nix b/krebs/2configs/shack/worlddomination.nix
index 838c1958..44176a34 100644
--- a/krebs/2configs/shack/worlddomination.nix
+++ b/krebs/2configs/shack/worlddomination.nix
@@ -75,6 +75,7 @@ let
};
wdpath = "/usr/worlddomination/wd.lst";
esphost = "10.42.24.7"; # esp8266
+ afrihost = "10.42.25.201"; # africa
timeout = 10; # minutes
in {
systemd.services.worlddomination = {
@@ -88,4 +89,16 @@ in {
PermissionsStartOnly = true;
};
};
+
+ systemd.services.worlddomination-africa = {
+ description = "run worlddomination africa";
+ wantedBy = [ "multi-user.target" ];
+ serviceConfig = {
+ User = "nobody"; # TODO separate user
+ ExecStart = "${pkg}/bin/push-led ${afrihost} ${pkg}/${wdpath} loop ${toString timeout}";
+ Restart = "always";
+ PrivateTmp = true;
+ PermissionsStartOnly = true;
+ };
+ };
}