summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/prometheus/unifi.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-06-20 22:21:56 +0200
committermakefu <github@syntax-fehler.de>2019-06-20 22:25:46 +0200
commit8225afec5b2e853d2e4eeae27adc5a39efcdae17 (patch)
tree2848442306c650c351808211ac1c2d380d18e4ba /krebs/2configs/shack/prometheus/unifi.nix
parent75f8b34296a237f350c47147e3a4cb313862e7f5 (diff)
wolf.r: init shack/prometheus config
Diffstat (limited to 'krebs/2configs/shack/prometheus/unifi.nix')
-rw-r--r--krebs/2configs/shack/prometheus/unifi.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/krebs/2configs/shack/prometheus/unifi.nix b/krebs/2configs/shack/prometheus/unifi.nix
new file mode 100644
index 00000000..401ecb02
--- /dev/null
+++ b/krebs/2configs/shack/prometheus/unifi.nix
@@ -0,0 +1,10 @@
+{lib, ... }:
+{
+ services.prometheus.exporters.unifi = {
+ enable = true;
+ unifiAddress = "https://unifi.shack:8443/";
+ unifiInsecure = true;
+ unifiUsername = "prometheus"; # needed manual login after setup to confirm the password
+ unifiPassword = lib.replaceChars ["\n"] [""] (builtins.readFile <secrets/shack/unifi-prometheus-pw>);
+ };
+}