summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/prometheus/unifi.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2019-09-11 10:34:02 +0200
committertv <tv@krebsco.de>2019-09-11 10:34:02 +0200
commit0182f1bd64973e93d4cf4c30b6005708b7e09240 (patch)
treef5a318fee1572b9b35f9f321d4ac707bc7935792 /krebs/2configs/shack/prometheus/unifi.nix
parente388d02623b98bad5db52b29ea1ef1f494fddae8 (diff)
parent5d24345ff430df38263c113041070a900c23131e (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'krebs/2configs/shack/prometheus/unifi.nix')
-rw-r--r--krebs/2configs/shack/prometheus/unifi.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/krebs/2configs/shack/prometheus/unifi.nix b/krebs/2configs/shack/prometheus/unifi.nix
new file mode 100644
index 00000000..401ecb02
--- /dev/null
+++ b/krebs/2configs/shack/prometheus/unifi.nix
@@ -0,0 +1,10 @@
+{lib, ... }:
+{
+ services.prometheus.exporters.unifi = {
+ enable = true;
+ unifiAddress = "https://unifi.shack:8443/";
+ unifiInsecure = true;
+ unifiUsername = "prometheus"; # needed manual login after setup to confirm the password
+ unifiPassword = lib.replaceChars ["\n"] [""] (builtins.readFile <secrets/shack/unifi-prometheus-pw>);
+ };
+}