summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/powerraw.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-06-05 19:13:25 +0200
committermakefu <github@syntax-fehler.de>2021-06-05 19:13:30 +0200
commitb37a74c688e272587433874cb779bdc367e127a2 (patch)
tree8752ab92fb46f9f7e0c19fff545e3c26285ca13c /krebs/2configs/shack/powerraw.nix
parent0ec91f780275da036c7bdba85897645d6c4c101b (diff)
puyak.r/shack: isSystemUser everything
Diffstat (limited to 'krebs/2configs/shack/powerraw.nix')
-rw-r--r--krebs/2configs/shack/powerraw.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/krebs/2configs/shack/powerraw.nix b/krebs/2configs/shack/powerraw.nix
index cc3692e8..43c74358 100644
--- a/krebs/2configs/shack/powerraw.nix
+++ b/krebs/2configs/shack/powerraw.nix
@@ -14,7 +14,10 @@ let
in {
# receive response from light.shack / standby.shack
networking.firewall.allowedUDPPorts = [ 11111 ];
- users.users.powermeter.extraGroups = [ "dialout" ];
+ users.users.powermeter = {
+ extraGroups = [ "dialout" ];
+ isSystemUser = true;
+ };
# we make sure that usb-ttl has the correct permissions
# creates /dev/powerraw