summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/repo-sync.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-07-22 15:12:06 +0200
committerlassulus <lassulus@lassul.us>2017-07-22 15:20:09 +0200
commitb4ad7cd86d59fbc003392068f6abec6f96720163 (patch)
tree3d687778f0fc4e68a0f9f30dc28a21f4e9f18dbd /krebs/2configs/repo-sync.nix
parent657e099f4a42c5fd707872b914d8d84ff939e849 (diff)
krebs: merge cgit-mirror into repo-sync
Diffstat (limited to 'krebs/2configs/repo-sync.nix')
-rw-r--r--krebs/2configs/repo-sync.nix84
1 files changed, 62 insertions, 22 deletions
diff --git a/krebs/2configs/repo-sync.nix b/krebs/2configs/repo-sync.nix
index 637a26e3..87a8bd82 100644
--- a/krebs/2configs/repo-sync.nix
+++ b/krebs/2configs/repo-sync.nix
@@ -1,31 +1,71 @@
{ config, lib, pkgs, ... }:
-with lib;
-{
- krebs.repo-sync = let
- # TODO addMirrorURL function
- mirror = "git@wolf:stockholm-mirror";
- in {
- enable = true;
- repos.stockholm = {
- branches = {
- makefu = {
- origin.url = http://cgit.gum/stockholm ;
- mirror.url = mirror;
+with import <stockholm/lib>;
+
+let
+ mirror = "git@${config.networking.hostName}:";
+
+ defineRepo = name: announce: let
+ repo = {
+ public = true;
+ name = mkDefault "${name}";
+ cgit.desc = mkDefault "mirror for ${name}";
+ cgit.section = mkDefault "mirror";
+ hooks = mkIf announce (mkDefault {
+ post-receive = pkgs.git-hooks.irc-announce {
+ nick = config.networking.hostName;
+ verbose = false;
+ channel = "#retiolum";
+ server = "ni.r";
+ branches = [ "newest" ];
};
- tv = {
- origin.url = http://cgit.ni.r/stockholm;
- mirror.url = mirror;
+ });
+ };
+ in {
+ rules = with git; singleton {
+ user = with config.krebs.users; [
+ config.krebs.users."${config.networking.hostName}-repo-sync"
+ ];
+ repo = [ repo ];
+ perm = push ''refs/*'' [ non-fast-forward create delete merge ];
+ };
+ repos."${name}" = repo;
+ };
+
+ sync-retiolum = name:
+ {
+ krebs.repo-sync.repos.${name} = {
+ branches = {
+ makefu = {
+ origin.url = "http://cgit.gum/${name}";
+ mirror.url = "${mirror}${name}";
+ };
+ tv = {
+ origin.url = "http://cgit.ni.r/${name}";
+ mirror.url = "${mirror}${name}";
+ };
+ nin = {
+ origin.url = "http://cgit.onondaga.r/${name}";
+ mirror.url = "${mirror}${name}";
+ };
+ lassulus = {
+ origin.url = "http://cgit.lassul.us/${name}";
+ mirror.url = "${mirror}${name}";
+ };
};
- lassulus = {
- origin.url = http://cgit.prism/stockholm ;
- mirror.url = mirror;
+ latest = {
+ url = "${mirror}${name}";
+ ref = "heads/newest";
};
};
- latest = {
- url = mirror;
- ref = "heads/master";
- };
+ krebs.git = defineRepo name true;
};
+
+in {
+ krebs.repo-sync = {
+ enable = true;
};
+ imports = [
+ (sync-retiolum "stockholm")
+ ];
}