summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/repo-sync.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-07-14 00:17:58 +0200
committertv <tv@krebsco.de>2017-07-14 00:21:02 +0200
commit58380c82848c3db0bd6c3d74904153f3464c2098 (patch)
treedcefa424c037ef13edba18967143b3290dc739cb /krebs/2configs/repo-sync.nix
parentc213968c44befe32f115ec0122accebdabd89582 (diff)
merge shared into krebs
Diffstat (limited to 'krebs/2configs/repo-sync.nix')
-rw-r--r--krebs/2configs/repo-sync.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/krebs/2configs/repo-sync.nix b/krebs/2configs/repo-sync.nix
new file mode 100644
index 00000000..637a26e3
--- /dev/null
+++ b/krebs/2configs/repo-sync.nix
@@ -0,0 +1,31 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+{
+ krebs.repo-sync = let
+ # TODO addMirrorURL function
+ mirror = "git@wolf:stockholm-mirror";
+ in {
+ enable = true;
+ repos.stockholm = {
+ branches = {
+ makefu = {
+ origin.url = http://cgit.gum/stockholm ;
+ mirror.url = mirror;
+ };
+ tv = {
+ origin.url = http://cgit.ni.r/stockholm;
+ mirror.url = mirror;
+ };
+ lassulus = {
+ origin.url = http://cgit.prism/stockholm ;
+ mirror.url = mirror;
+ };
+ };
+ latest = {
+ url = mirror;
+ ref = "heads/master";
+ };
+ };
+ };
+}