summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/repo-sync.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-08-29 17:42:00 +0200
committerlassulus <lassulus@lassul.us>2018-08-29 17:42:15 +0200
commit427488be8176024e758fe40be32593a10fb1a53b (patch)
tree19a7e39c0249b22a2a25e24650b6be1a3ffebf3a /krebs/2configs/repo-sync.nix
parentaf2753507d65e01d088161122ce5663c181a46aa (diff)
repo-sync: add konsens for krops & stockholm
Diffstat (limited to 'krebs/2configs/repo-sync.nix')
-rw-r--r--krebs/2configs/repo-sync.nix26
1 files changed, 25 insertions, 1 deletions
diff --git a/krebs/2configs/repo-sync.nix b/krebs/2configs/repo-sync.nix
index 7c3b2c90..813dc154 100644
--- a/krebs/2configs/repo-sync.nix
+++ b/krebs/2configs/repo-sync.nix
@@ -3,6 +3,10 @@
with import <stockholm/lib>;
let
+ konsens-user = {
+ name = "konsens";
+ pubkey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIKKozGNGBAzHnyj6xUlsjGxxknyChXvuyrddkWVVnz7";
+ };
mirror = "git@${config.networking.hostName}:";
defineRepo = {
@@ -20,7 +24,7 @@ let
verbose = false;
channel = "#xxx";
server = "irc.r";
- branches = [ "newest" ];
+ branches = [ "master" "newest" ];
};
};
};
@@ -38,6 +42,13 @@ let
perm = push ''refs/*'' [ non-fast-forward create delete merge ];
}
{
+ user = [
+ konsens-user
+ ];
+ repo = [ repo ];
+ perm = push ''refs/heads/master'' [ create merge ];
+ }
+ {
user = attrValues config.krebs.users;
repo = [ repo ];
perm = fetch;
@@ -108,6 +119,19 @@ in {
krebs.repo-sync = {
enable = true;
};
+ krebs.konsens = {
+ enable = true;
+ repos = {
+ krops = { branchesToCheck = [ "lassulus" "tv" ]; };
+ stockholm = {};
+ };
+ };
+ krebs.secret.files.konsens = {
+ path = "/var/lib/konsens/.ssh/id_ed25519";
+ owner = konsens-user;
+ source-path = "${<secrets/konsens.id_ed25519>}";
+ };
+
imports = [
(sync-retiolum { name = "the_playlist"; desc = "Good Music collection + tools"; section = "art"; })