summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/repo-sync.nix
diff options
context:
space:
mode:
authorlassulus <lass@blue.r>2018-08-25 12:04:22 +0200
committerlassulus <lass@blue.r>2018-08-25 12:04:22 +0200
commit413e0689acd4f6b322f9996950927ebd41d0e58c (patch)
tree2d794d8ad690caa8bb1bdd0ae835123906f25727 /krebs/2configs/repo-sync.nix
parent362c7008486b48bfc57eb1c33bf8b5b60cccee44 (diff)
repo-sync: remove staging branches, style
Diffstat (limited to 'krebs/2configs/repo-sync.nix')
-rw-r--r--krebs/2configs/repo-sync.nix29
1 files changed, 7 insertions, 22 deletions
diff --git a/krebs/2configs/repo-sync.nix b/krebs/2configs/repo-sync.nix
index 2a7160a5..7c3b2c90 100644
--- a/krebs/2configs/repo-sync.nix
+++ b/krebs/2configs/repo-sync.nix
@@ -29,10 +29,10 @@ let
{
user = with config.krebs.users; [
config.krebs.users."${config.networking.hostName}-repo-sync"
+ jeschli
lass
- tv
makefu
- jeschli
+ tv
];
repo = [ repo ];
perm = push ''refs/*'' [ non-fast-forward create delete merge ];
@@ -54,35 +54,20 @@ let
{
krebs.repo-sync.repos.${name} = {
branches = {
- makefu = {
- origin.url = "http://cgit.gum/${name}";
- mirror.url = "${mirror}${name}";
- };
- tv = {
- origin.url = "http://cgit.ni.r/${name}";
- mirror.url = "${mirror}${name}";
- };
- nin = {
- origin.url = "http://cgit.onondaga.r/${name}";
- mirror.url = "${mirror}${name}";
- };
lassulus = {
origin.url = "http://cgit.lassul.us/${name}";
mirror.url = "${mirror}${name}";
};
- makefu-staging = {
+ makefu = {
origin.url = "http://cgit.gum/${name}";
- origin.ref = "heads/staging";
mirror.url = "${mirror}${name}";
};
- tv-staging = {
- origin.url = "http://cgit.ni.r/${name}";
- origin.ref = "heads/staging";
+ nin = {
+ origin.url = "http://cgit.onondaga.r/${name}";
mirror.url = "${mirror}${name}";
};
- nin-staging = {
- origin.url = "http://cgit.onondaga.r/${name}";
- origin.ref = "heads/staging";
+ tv = {
+ origin.url = "http://cgit.ni.r/${name}";
mirror.url = "${mirror}${name}";
};
};